mView for V8.53 and Later Motion Software

mView is an elevator monitoring application. Through Ethernet, the computer running mView may be connected directly to a single Motion 2000 or Motion 4000 controller or to multiple controllers. Using mView you can:

- View elevator position and door status
- Check the status of the elevator including the mode of operation, car status, and error messages
- View the event log
- Check the status of the diagnostic flags
- Register car and hall calls
- Review a 14-day hall call performance log

The 14-day hall call performance log uses a Sequel Express database running on the mView PC. The reporting function uses a second, independent IP address/connection on each controller because, once started, it continuously collects data, regardless of the mView connection status, as long as the PC is running and the connection is maintained. Data accumulates a day at a time for the maximum 14 days at which point, the oldest day data is deleted as a new day is recorded. Depending upon firmware, up to five controllers may be actively monitored at any one time; each will write to its own database instance.

mView is designed for wired, “local” Ethernet connection to the elevator controls. If you need the ability to connect remotely through “Internet” connectivity, the MCE iReport Client and Server product, which provides more extensive services, will be required.

This user guide contains:

- PC Setup (see “PC Setup” on page 2)
- Controller Setup (see “Controller Setup” on page 4)
- Physical Connections (see “Physical Connections” on page 5)
- Installing mView (see “Installing mView” on page 6)
- mView Start Up (see “mView Start Up” on page 6)
- mView Main Screen (see “mView Main Screen” on page 9)
- Diagnostic Flags (see “View - Diagnostics - Flags” on page 13)
- Event Log (see “Call Registration” on page 15)
- Call Registration (see “Call Registration” on page 15)
- Reporting Service (see “Reporting Service / Hall Call Performance” on page 16)

---

1. Ethernet is the default hardware connection method. CAN is available.
PC Setup
Set up the PC according to the manufacturer instructions. Once you have the PC physically set up, power it up to see that it boots properly.

Setting the PC IP Address
If you purchased your PC from MCE, the IP address will already have been set. The equipment installer should not have to set the PC IP address.

Note
Before you begin any TCP/IP setup, please check the MCE prints for the job. There may be other specific TCP/IP or installation instructions for your site.

Depending on the PC operating system, you may see some slight differences in the dialogs presented as you make settings.

1. Start the PC.
2. From the Windows Start menu, open the Control Panel.
3. Open Network Connections.
4. Double-click the Local Area Connection icon.
5. Click Properties.
6. In the Local Area Connection Properties dialog, select Internet Protocol (TCP/IP).

7. Click Properties to open the Internet Protocol (TCP/IP) Properties dialog.

8. Click the radio button next to Use the Following IP address and type in the desired IP address. If you are using MCE default IP address settings, set the PC IP Address to 192.168.191.101.

9. Set the Subnet Mask to 255.255.255.0.

10. Click OK and follow any instructions to save the changes you made.

It is important that the PC have only one IP address assigned. Click the Advanced button and verify that the PC is configured for only a single IP Address (192.168.191.101). If there is more than one IP Address, highlight the additional IP Address and then click Remove.
Controller Setup
The controllers will have been configured at the factory and will be ready for physical Ethernet connections. The job prints shipped with your order will provide the individual TCP/IP addresses used for your connections.

TCP/IP Addressing
TCP/IP addresses are set at the factory before shipment and clearly identified on the job prints. The system installer should not need to set addresses. This information is provided for building IT personnel. MCE uses Lantronix Xport devices which are most easily configured using software that may be downloaded from the Lantronix web site.

The table below lists MCE default IP addresses. Your job prints provide specific instructions as to how your IP addresses are set.

Table 1. MCE Default mView TCP/IP Addresses

<table>
<thead>
<tr>
<th>ID</th>
<th>mView MPU Board Connection</th>
<th>Data Collection CHP Board Connection</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>192.168.191.011 (012 for duplex car B)</td>
<td>192.168.191.202</td>
</tr>
<tr>
<td>2</td>
<td>192.168.191.031 (032 for duplex car B)</td>
<td>192.168.191.204</td>
</tr>
<tr>
<td>3</td>
<td>192.168.191.051 (052 for duplex car B)</td>
<td>192.168.191.206</td>
</tr>
<tr>
<td>4</td>
<td>192.168.191.071 (072 for duplex car B)</td>
<td>192.168.191.208</td>
</tr>
<tr>
<td>5</td>
<td>192.168.191.091 (092 for duplex car B)</td>
<td>192.168.191.110</td>
</tr>
</tbody>
</table>

Default Subnet Mask for all ports is 255.255.255.000; gateway default is 0.0.0.0
Physical Connections

- No single Ethernet cable may be longer than 100m (328 feet).
- If any single cable run will exceed 100m, an Ethernet hyper extender or fiber-optic to Ethernet converters must be used (available from MCE).
- All IP addresses on an interconnected network must be unique.
- Use shielded CAT 5e or CAT 6 STP (shielded twisted pair) cable and follow all manufacturer recommendations.

Figure 1. Ethernet Connections

1. Connect the PC Ethernet connector (network interface card) to the Ethernet switch.
2. Connect the Ethernet (Xport) on the HC-CHP Can board to the Ethernet switch.
3. Connect the Ethernet (Xport) on the HC-MPU board to the Ethernet switch.
4. Repeat 2 and 3 for additional controllers.
mView Elevator Monitoring

Installing mView

If you purchased your mView PC from MCE, mView was installed at the factory. If not, you will need to install mView from a CD-ROM or other source. There will be a Read Me text file available on the installing media that you should read before beginning installation.

**Note**

Unless you have PC administrative skills or have access to IT personnel, leave the default settings unchanged as you install mView. At a point during installation, a dialog will ask you to select the database location. From the browse list, select the local database server. (It will probably be the only available selection in the list.)

1. Insert the mView CD into the computer CD-ROM drive and launch the CD.
2. From the mView folder, run LaunchSetup.bat.
3. The LaunchSetup batch file will check for a previously installed version of mView and, if found, will remove it. It will then launch the mView Installation Wizard. As the Wizard runs, follow on-screen instructions.

After installation, the mView icon will appear on your desktop.

mView Start Up

Start the mView application. The first time you start mView, you will see a “blank” screen because it is not connected to a controller. If mView was installed by MCE, connections for both mView and for the data collection service (hall call performance) will have been configured and a connection may already be active; if so, you will see an elevator car and various operating flags. An unpopulated screen is shown below.

**Figure 2. mView Main Screen with no Active Connection**
Connect to a Controller

1. Click the Open Connection button or select File > Connection > Open.

2. The Open dialog is displayed. Double-click the connection you wish to open or click to highlight the connection and then click Open.

3. The connection opens and the Status tab is displayed. If the connection has not yet been created, you must create it before you can connect to the controller. Please refer to “Create a Connection” on page 8.

Figure 3. mView Main Screen with Connection Active
Create a Connection
If you need to create a connection:

1. Click File > Connection > New
2. The Connection dialog opens. Enter the following information:
   • Connection name (your choice)
   • Controller type (select from drop down list)
   • Connection medium select from drop down list)
   • IP address (see note below)
   • Click OK
   • Please refer to “Connect to a Controller” on page 7.

Note
Refer to the job prints for specific controller addresses. When entering IP addresses, do not use leading zeros, i.e., .020 is entered as .20.

Edit a Connection
Should you need to edit an existing connection:

1. Select File > Connection > Edit.
2. The same dialog used to create a connection (previously described) will appear.

Close a Connection
1. Click the Close Connection button or select File > Connection > Close.

Delete a Connection
1. Select File > Connection > Edit.
2. Right-click on the connection you wish to delete.
3. Select Delete from the popup menu.
mView Main Screen

The mView main screen is shown below. Detailed descriptions are provided on the following pages.
Elevator Status

**Processor health**

These indicators light green when the associated processors are functioning normally.

**Position**

- Actual: Distance from the bottom landing to present car position (Traction only).
- Sensor A: Position of car as detected by landing system sensor A (Traction only).
- Sensor B: Position of car as detected by landing system sensor B (Traction only).
- Sensor dif.: Difference between Sensor A and Sensor B readings (Traction only).

**Motion**

- Cmd direction: Indicates the car direction commanded by the control system.
- Actual direction: Indicates actual direction of car travel.

**In-service**

- Safety OK: Indicates the Safety string is made up.
- System comm: System CAN communication functioning properly.
- Hall call service: Hall call service active and operating properly.

**Leveling sensors**

- Up leveling marker (Front and Rear): Lights when ULM is activated.
- Door zone (Front and Rear): Lights when DZ is activated.
- Down leveling marker (Front and Rear): Lights when DLM is activated.
Door Lock
• Front and Rear: Indicates when the front and rear door locks are made up (final confirmation of gates, hoistway locks and door locks).

Faults
• All active fault messages are displayed in the Faults list box. The controller user guide contains a complete list of fault and status messages.

Car Status
• All active car status messages are displayed in the Car status list box. The controller user guide contains a complete list of fault and status messages.

Detailed Hoistway
**mView Elevator Monitoring**

**View - Diagnostics - Event Log**

The Event Log (View > Diagnostics > Event Log) provides a way to view events logged internally by the Motion 2000/4000 controller. See the controller user guide for a complete list of messages and troubleshooting information.

The Controller Event Log lists the following for the events recorded:

<table>
<thead>
<tr>
<th>Date</th>
<th>Time</th>
<th>Error Number</th>
<th>Error Description</th>
<th>Reason Code</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>10/22/11</td>
<td>03:31:07 PM</td>
<td>4032</td>
<td>Down normal limit open</td>
<td>1</td>
<td>OFF</td>
</tr>
<tr>
<td>10/22/11</td>
<td>03:31:07 PM</td>
<td>4032</td>
<td>Bottom floor or top floor demand</td>
<td>0</td>
<td>OFF</td>
</tr>
<tr>
<td>10/22/11</td>
<td>03:30:57 PM</td>
<td>4032</td>
<td>Down normal limit open</td>
<td>1</td>
<td>ON</td>
</tr>
<tr>
<td>10/22/11</td>
<td>03:50:56 PM</td>
<td>5</td>
<td>Synchronization operation</td>
<td>0</td>
<td>OFF</td>
</tr>
<tr>
<td>10/22/11</td>
<td>03:50:26 PM</td>
<td>5</td>
<td>Synchronization operation</td>
<td>0</td>
<td>ON</td>
</tr>
<tr>
<td>10/22/11</td>
<td>03:00:26 PM</td>
<td>6</td>
<td>Bottom floor or top floor demand</td>
<td>0</td>
<td>ON</td>
</tr>
<tr>
<td>10/22/11</td>
<td>03:01:07 PM</td>
<td>4032</td>
<td>Down normal limit open</td>
<td>1</td>
<td>OFF</td>
</tr>
<tr>
<td>10/22/11</td>
<td>03:01:07 PM</td>
<td>6</td>
<td>Bottom floor or top floor demand</td>
<td>0</td>
<td>OFF</td>
</tr>
<tr>
<td>10/22/11</td>
<td>03:00:57 PM</td>
<td>4032</td>
<td>Down normal limit open</td>
<td>1</td>
<td>ON</td>
</tr>
<tr>
<td>10/22/11</td>
<td>03:00:56 PM</td>
<td>5</td>
<td>Synchronization operation</td>
<td>0</td>
<td>OFF</td>
</tr>
<tr>
<td>10/22/11</td>
<td>03:00:26 PM</td>
<td>5</td>
<td>Synchronization operation</td>
<td>0</td>
<td>ON</td>
</tr>
<tr>
<td>10/22/11</td>
<td>03:00:26 PM</td>
<td>6</td>
<td>Bottom floor or top floor demand</td>
<td>0</td>
<td>ON</td>
</tr>
<tr>
<td>10/19/11</td>
<td>03:01:07 PM</td>
<td>4032</td>
<td>Down normal limit open</td>
<td>1</td>
<td>OFF</td>
</tr>
<tr>
<td>10/19/11</td>
<td>03:01:07 PM</td>
<td>6</td>
<td>Bottom floor or top floor demand</td>
<td>0</td>
<td>OFF</td>
</tr>
<tr>
<td>10/19/11</td>
<td>03:00:57 PM</td>
<td>4032</td>
<td>Down normal limit open</td>
<td>1</td>
<td>ON</td>
</tr>
<tr>
<td>10/19/11</td>
<td>03:00:56 PM</td>
<td>5</td>
<td>Synchronization operation</td>
<td>0</td>
<td>OFF</td>
</tr>
<tr>
<td>10/19/11</td>
<td>03:00:26 PM</td>
<td>5</td>
<td>Synchronization operation</td>
<td>0</td>
<td>ON</td>
</tr>
<tr>
<td>10/19/11</td>
<td>03:00:26 PM</td>
<td>6</td>
<td>Bottom floor or top floor demand</td>
<td>0</td>
<td>ON</td>
</tr>
<tr>
<td>10/18/11</td>
<td>03:31:07 PM</td>
<td>4032</td>
<td>Down normal limit open</td>
<td>1</td>
<td>OFF</td>
</tr>
<tr>
<td>10/18/11</td>
<td>03:10:07 PM</td>
<td>4032</td>
<td>Bottom floor or top floor demand</td>
<td>0</td>
<td>OFF</td>
</tr>
</tbody>
</table>

- Error number: A number passed from the controller to mView to identify the error.
- Reason Code: Provides additional information about the error, primarily for use by MCE Technical Support.
- Error Description - (If Unknown:, the mView version is older than the controller version and the Error Number is “unknown” to mView. Use the controller “View Event Calendar” (F5) option to identify the error.

**Save event log / Open event log**

The Event Log can be saved to a file for future reference. To save a Controller Event Log to a file:

- Click the Save button on the Controller > Diagnostics > Event Log tab.
- Navigate to the folder you want to save the file in.
- Name the file and click Save.

The Event Log is saved as a .txt file and can be viewed using most text processing applications.

**Refresh**

The refresh button is used to request the latest data from the controller.
View - Diagnostics - Flags

To view the Diagnostic Flags, select Diagnostic Flags from the View > Diagnostics menu, then select the flags you wish to view. A complete list of the Flags and Variables is provided in the controller user guide.

### MPU Flags

<table>
<thead>
<tr>
<th>Diagnostic Flags</th>
<th>MPU Flags</th>
</tr>
</thead>
<tbody>
<tr>
<td>MPU Flags</td>
<td>MP12</td>
</tr>
<tr>
<td></td>
<td>MP13</td>
</tr>
<tr>
<td></td>
<td>MP14</td>
</tr>
<tr>
<td></td>
<td>MP15</td>
</tr>
</tbody>
</table>

### CTLA Flags

<table>
<thead>
<tr>
<th>Diagnostic Flags</th>
<th>CTLA Flags</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTLA Flags</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### CTLB Flags

<table>
<thead>
<tr>
<th>Diagnostic Flags</th>
<th>CTLB Flags</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTLB Flags</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### CTLC Flags

<table>
<thead>
<tr>
<th>Diagnostic Flags</th>
<th>CTLC Flags</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTLC Flags</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### Virtual Landing System

<table>
<thead>
<tr>
<th>Diagnostic Flags</th>
<th>Virtual landing system</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Instruction # 42-IS-0222, Rev A2
View - Diagnostics - Hall Call Performance
   This selection requires that reporting service be active for the controller being monitored.
   Please refer to “Reporting Service / Hall Call Performance” on page 16.

View - Hoistway
   This selection displays a simple hoistway view, showing car motion, position, door status, and actual speed.

View - Detailed Hoistway
   This selection displays a detailed hoistway view. Please refer to “Detailed Hoistway” on page 11.
Call Registration

The Call Registration panel is available while working on any screen in mView.

- Call Registration button : Opens the dialog used to register car or hall calls.

To register car calls:

1. Click the Car tab.
2. Select Front or Rear.
3. Click the desired floor button(s).
4. To close the dialog, click the “X” in the upper right corner.

To register hall calls:

1. Click the Front or Rear tab (or Hall tab if the car has only front doors).
2. Select Main Up, Main Down, Hospital Up or Hospital Down.
3. Click the desired floor button(s).
4. To close the dialog, click the “X” in the upper right corner.
**mView Elevator Monitoring**

**Reporting Service / Hall Call Performance**

The mView reporting service (Tools/Reporting Service) allows you to set up a reporting service for MCE Motion controllers. The reporting service collects hall call information from controllers and creates associated database instances on a local Sequel Server Express database. The Sequel Express database and required mView/Sequel interaction parameters are set up automatically when mView (with Reporting Service) is installed. Please refer to “Installing mView” on page 6.

Through the Reporting Service dialog, you set up an independent connection to any appropriately equipped Motion 2000 or Motion 4000 controller. Once created, a connection will start up automatically when the mView PC is launched and remain active until you shut the reporting service off or communications are extensively interrupted. Up to five controllers can be actively reporting at any one time. A 14-day, hall call performance log is maintained for each.

The 14-day hall call performance log data accumulates a day at a time for the maximum 14 days at which point, the oldest day data is deleted as a new day is recorded. While viewing a performance log for a particular controller, you can print the screen to capture a record of hall call activity.

While connected to a controller through mView, you select Diagnostics/Hall Call Performance from the View menu to display the hall call performance data for that controller.

**Setting Up a Reporting Service**

1. Select Reporting Service from the Tools menu.

If any reporting services connections have been created, they will be visible in the dialog.
2. To create a reporting services connection, click on the Add Dispatcher button.

3. When Add Dispatcher is clicked, the following dialog will appear:
   - Enter a name for the Reporting connection. This name must be exactly the same name used for the primary mView connection. Please refer to “Create a Connection” on page 8.
   - Enter the IP address provided for the HC-CHP board in the controller.
   - Select the controller type from the drop down list.
   - Select the Car ID provided.
   - Click OK.
**Editing a Dispatcher**
An elevator controller reporting connection may be edited any time mView is open just by selecting the connection from the list and clicking the Edit button.

**Starting/Stopping Data Collection**
Active data collection for any listed controller reporting connection may be started, stopped, or restarted any time mView is open by selecting the connection and clicking the appropriate action button.

**Stopping Reporting**
Globally (affects all controllers) enabling or disabling the reporting function may be accomplished any time mView is active by clicking the appropriate button.

**Viewing the Hall Call Performance Log**
The hall call performance log for a particular controller may only be viewed when mView is actively connected to that controller (mView and reporting function connected to the same, named controller). To open the hall call performance report:

1. Select Diagnostics/Hall Call Performance from the View menu.
   - Remember that the reporting connection must have been active long enough that hall call data has actually been reported.
2. Select the call type to be reported upon (Main, Main Rear, Aux Front, Aux Rear).
3. Wait a few moments while data is refreshed and presented.
Customizing the Display    Display colors for up and down calls may be changed; the data display may be resized.

- Change Up or Down colors by clicking the associated button and selecting a color from the palette displayed.
- Zoom in on the chart by clicking and dragging in a time slot.

Printing the Hall Call Performance Chart
1. Open the performance chart.
2. Drag it out of its docked position in the main screen.
3. Size it appropriately.
4. Press and hold the keyboard Alt key and click on the Print Screen key.
5. Open Wordpad or another word processor.
6. Select Edit/Paste to paste the performance chart in the application.
7. Print.